
 

 

 

IXP120 Software 
QUICK START GUIDE 

Scope of Document 

This document provides a brief overview of the IXP120 Software. 

 

Document Conventions 

We use the following conventions in this document: 

 

 
Note – points out extra information 

 
Tip – points out alternative methods to perform a task 

 
Important – points out important information 

 
Warning – points out potential danger to you or the 

product 

 

Before You Begin 

Have the following available: 

 

 The IXP120 Software CD  

 Serial number and fixed address of each IXP121 Controller 
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Where to Find Information 

Additional information is available in the following resource: 

 

 IXP120 Software Help—part of the IXP120 Software.  Help 

provides detailed information on all aspects of the IXP120 

System. 

 IXP121 Controller Hardware Installation Manual—bundled 

with the IXP121 Controller. 

 IXP120 Product Specification Catalogue—available at 

www.impro.net.  

 How to Set Up the IXP120 Database on a Dedicated Server 

document—for advanced Users only. 

  

http://www.impro.net/
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Sequence of Operations 

 

Follow this sequence of steps to set up and configure the IXP120 

Software: 

 

 
Figure 1:  Setup Flowchart 

 

Once the Software is installed, repeat steps 2 to 4 only, to configure a 

Site. 
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Installation 

PC Requirements 

Make sure your PC meets the following minimum requirements: 

 

Component Minimum Requirement 

Processor Pentium II, 600 MHz 

RAM 256 Mb 

Hard Disk 2 Gb available space 

Graphics 1 024 x 768 

Modem 56 K, USB or Serial 

Ports USB and RS232 

Removable Storage CD-ROM Drive 

Operating System Microsoft Windows NT, 2000, or XP Professional 

Table 1:  Minimum PC Requirements 

 

Software Installation 

Firebird Server 

Install the Firebird Server as follows: 

 

1. Insert the IXP120 CD into your PC’s CD-ROM drive. 

2. Wait for the CD to auto-run. 

3. Select the Browse CD option. 

4. From the Firebird folder, select Setup Firebird Project. 

5. At the Select Startup Language dialog, from the drop-down list 

select a language. 

6. Click the OK button. 
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Installation Wizard 

1. At the Welcome screen, click the Next button. 

2. At the Licence Agreement screen, select the I Accept the 

Agreement radio button. 

3. Click the Next button. 

4. Review the Information screen and then click the Next button. 

5. At the Select Destination Location screen, click the Next button. 

6. From the Select Components Screen, select the components for 

installation. 

7. Click the Next button. 

8. At the Select Start Menu Folder screen, click the Next button. 

 

 
Figure 2:  Select Additional Tasks Screen 

9. At the Select Additional Tasks screen, select that the following tasks 

run: 

 Use the Guardian to Control the Server 

 Run as a Service 

 Start Firebird Automatically Every time you Boot up 

 Install Control Panel Applet 

 Generate client Library as GDS32.DLL for Legacy 

Application Support 

10. Click the Next button. 

11. At the Ready to Install screen, click the Install button. 

12. Review the Information screen, then click the Next button. 
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13. At the final screen, select the Start Firebird Service Now 

checkbox. 

14. Click on the Finish button. 

 

IXP120 Software 

Install the IXP120 Software as follows: 

 

1. Insert the IXP120 CD into your PC’s CD-ROM drive. 

2. Wait for the CD to auto-run. 

3. Click on the Install IXP120 option. 

4. Follow the on-screen instructions. 

5. Click on the Exit option. 

 

Initialise the Software 

 
Before starting the IXP120 Software, ensure that the 

Registration Reader or the IXP121 Controller is connected to 

the Host PC. 

 

1. In Windows®, select Start>Programs>IXP120>IXP120. 

2. Enter your Username and Password. 

 

 
The default Username is SYSDBA and the default Password 

masterkey. 

 

  



 
 

 

IXP321-0-0-GB-02 October 2007 Page 7 

 

Configure COM Ports 

You need to specify the locations of serial devices before they will work 

with the IXP120 Software.  

 

  
Windows treats USB devices in a similar manner to serial 

devices. 

 

The default setting is that NO Registration Reader is present.  

Therefore, the Software does not try to detect one.  The default COM 

port is COM1. 

 

Registration Reader Present 

To configure the COM port manually, proceed as follows: 

 

1. On the menu, select File>System. 

2. Select the Enable Registration Reader checkbox. 

3. Select the COM port used for the Registration Reader. 

4. Click the   button. 

 

 
If the Registration Reader is unlocked, the IXP120 Software 

has access to multiple Sites. However, if the Registration 

Reader is locked, the IXP120 Software is restricted to a single 

Site.  

 

Registration Reader Not Present 

If a Registration Reader is not present, proceed as follows: 

 

1. On the menu, select File>System. 

2. De-select the Enable Registration Reader checkbox. 

3. From the Select Tag Reader on Site 1 drop-down list choose a 

Reader to use for Tag registration. 
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4. Select the COM port used for the IXP121 Controller, or select an 

empty COM port if the Controller uses an Ethernet or modem 

connection. 

5. Click the   button. 

 

 
If a Registration Reader is not present, register Tags at the 

selected Tag Reader of the Controller.  Note that doing this 

results in a Denied Unknown transaction in the Database. 

 

If your IXP121 uses a Modem, proceed as follows: 

 

1. On the menu, select File > System. 

2. Select the COM port used for the Modem. 

3. Click the   button. 

 

 
If a Modem is not used, select an empty COM port option. 

 

 
Ensure the Registration Reader and Modem are connected to 

the Host PC before starting the IXP120 Software. 

 

 
Use Windows’ Device Manager to find out the COM port used 

by the IXP121 Controller or Registration Reader.  The following 

figure illustrates an ImproX hardware device connected to the 

Host PC. 
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Figure 3:  Device Manager Dialog 

      

 
Do not select COM ports with conflicting IRQs for the 

Registration Reader and Modem.  For example, do not select 

COM1 and COM3, or COM2 and COM4 together. 
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Understand the Interface 

 
Figure 4:  Work Area 

 

A – Menu bar  

Includes drop-down menus  

B – Toolbar 

Includes icon shortcuts 

C – Task pane  

Displays the selected task 

D – Monitor pane 

Provides real-time 

monitoring for: 

 Transactions 

 Alarms 

 Door Statuses 

E – Status bar 

F – Message Display 

G – Name of Active Site 

H – Active connection to 

site Database 

 Green light is active 

 Red light is inactive 

I – Active connection to 

site Controller 

 Green light is active 

 Red light is inactive
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Toolbar Shortcuts 

In addition to the Menu bar, use the Toolbar to access important tasks. 

 

 
Figure 5:  Toolbar 

 

Using Help 

The IXP120 Software has an integrated context-sensitive Help system.  

Information not covered in the guide is covered in Help.  Do one of the 

following to activate Help: 

 

 On the Toolbar, click the  button. 

 On the Menu, select Help > Help Topics. 
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Using IXP120 Software 

Configure Sites 

Do the following to configure a Site: 

 

 
Figure 6:  Configuration Flowchart 
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Create a New Site 

You must create a new Site by creating a new Site Directory Entry 

before you can configure your System. You may organize Sites in 

groups for convenience.   

 

To create a new Site, proceed as follows: 

 

1. On the menu, select Sites>Site Directory. 

2. Leave the Select Site Group option as Default Group. 

3. Click the  button. 

4. Enter a name for the Site. 

5. Select a Communication Port. 

6. If the Site uses a Modem, enter a Telephone number for the 

Modem. 

7. Click the  button to save. 

 

 
The Controller’s Fixed Address is required for the Local 

Controller Port option. 

 

 
The Local Controller Port option is suitable for RS232 and 

USB. 

 

 
For the Ethernet option, press F1 on your keyboard to launch 

Help. Refer to the Create a New Site topic by browsing Quick 

Start>Configuration in the Help navigation pane. 

 

Edit an Existing Site 

To edit an existing Site’s setup, proceed as follows: 

 

1. On the menu, select Sites>Site Directory. 

2. Select a Site from the Site Directory panel. 

3. Edit the Site’s setup options. 

4. Click the  button to save. 

1 
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Select a Site 

To configure a Site, proceed as follows: 

 

1. On the menu, select Sites>Select Site. 

2. Select a Site Group from the drop-down menu. 

3. Select a Site from the Select Site window. 

4. Click the  button. 

 

Set-up the IXP121 Controller 

To initiate communication with the Controller for the first time, proceed 

as follows: 

 

1. On the menu select Sites>Connect Site. 

2. When prompted, select Yes to perform AutoID. 

 

Alternatively, after connecting, proceed as follows: 

 

1. On the menu, select Hardware>Auto ID Units. 

2. When prompted, select Yes to perform AutoID. 

 

To configure the Controller, proceed as follows: 

 

1. On the menu, select Configuration>Controller. 

2. Select a Mode. 

3. Select the Daylight Savings checkbox if applicable. 
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Add Doors 

A Door is a single physical point of entry or exit.  A Door supports one or 

two Reader Terminals.  To add a Door, proceed as follows: 

 

 

1. On the menu, select Configuration>Doors. 

2. Click the  button. 

3. Enter a name for the Door in the Name textbox. For example: 

FrontDoor. 

4. Select the Entry Terminal. 

5. Select the Exit Terminal if required. 

6. Click the  button to save. 

7. Repeat steps 1 to 6 for additional Doors. 

 

 
Default Tag Mode is automatically assigned as the daily Day 

Mode for the Door. 

 

Create Access Groups 

Access Groups use Access Patterns to define times of access for one or 

more Doors.  Tagholders with similar access requirements are assigned 

to a common Access Group.  To configure Access Groups, proceed as 

follows: 

 

1. On the menu, select Tags>Access Groups. 

2. Click the  button in the upper pane. 

3. Enter a name for the Access Group in the Name textbox. 

4. Click the  button to save the Access Group. 

 

 
You assign Tagholders to their Access Groups in Step 4 - Add 

Tagholders. 

 

 

 

3 

2 
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Create Access Patterns 

Access Groups use Access Patterns to determine times of access for 

each day of the week.  To add an Access Pattern to an existing Access 

Group, proceed as follows: 

 

1. Click the  button in the lower pane. 

2. Select the relevant days and times. 

3. Click the Doors tab. 

4. Select the relevant Doors from the right-hand panel. 

5. Click the  button to make the selected Door accessible. 

6. Click the  button to Save the Access Pattern. 

 

Configure Holidays 

Holidays are periods when access to Sites is restricted or customized.  

To configure Holidays, proceed as follows: 

 

1. On the menu, select Configuration>Holidays. 

2. Enter a name for the Holiday in the Name textbox. 

3. Define the Start Date. 

4. Define the End Date. 

5. Click the  button to save. 
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Add Tagholders 

To Add Tagholders individually, proceed as follows: 

 

1. On the menu, select Tags>Tagholders. 

2. Click the  button. 

3. Enter a Tagholder’s general information. 

4. Click the Tag tab. 

Click the  button. 

Present a Tag to the Registration Reader. 

Click the Read Tag button. 

Select a Tag Level. 

Select an Access Group. 

5. If the Tagholder is an Operator, Click the Operator tab. 

Select the This Tagholder is an Operator option. 

Enter the Operator UserID. 

6. Click the  button to Save. 

 

 
The Tagholder’s Last Name field is the only required field. 

 

 
Double-click an existing Tagholder ’s entry to edit it. 

 

Connect to Site 

When you save configuration changes, they are saved to the Site 

database only – unless there is an active connection with the IXP121 

Controller.   

 

 
The COM indicator on the status bar shows a green light if the 

Controller is connected.  Otherwise, the light is red. 

 

To connect to the Site Controller, proceed as follows: 

 

 On the menu, Select Sites>Connect Site. 

4 
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To disconnect from the Site Controller and database, proceed as 

follows: 

 

 On the menu, Select Sites>Disconnect Site. 

 

Start Full Upload 

A Full Upload writes data from the Site database to the IXP121 

Controller.  When you have completed configuring the Site, start a Full 

Upload as follows: 

 

On the menu, select Configuration>Start Full Upload. 

 

 
The IXP121 Controller is temporarily off-line during a Full 

Upload and all data in the Controller buffer is erased. 

Therefore, the Controller canno process transactions. 

 

 
Always perform a Full Upload after the IXP121 Controller has 

had a Firmware upgrade. 
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Advanced Features 

Door Mode Patterns 

Door Mode Patterns define operational times and parameters for a door.  

They are configurable for each day of the week.  To define a new Door 

Mode Pattern, proceed as follows: 

 

1. On the menu, select Configuration>Doors. 

2. Click the Door Mode Patterns tab. 

3. Click the  button. 

4. Enter a name in the Pattern Name textbox. 

 

Add Pattern Time Slots 

Each Door Mode Pattern has up to eight Pattern Time Slots.  The first 

Pattern Time Slot has a default access period of 24 hours.  To add a 

Pattern Time Slot, proceed as follows: 

 

1. Change the End Time value of the first Pattern Time Slot and press 

[Enter] on your keyboard. 

2. A new Pattern Time Slot is created.  It has a Start Time value equal 

to the End Time value of the first Pattern Time Slot. 

3. Click on the other options of the Pattern Time Slot, and select 

values from a drop down menu. 

4. Click the  button to Save. 

 

 
The Default Tag Mode pattern is not configurable.  Therefore, 

you cannot create Pattern Time Slots for it.  It is automatically 

assigned to new Doors. 
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Assign Door Mode Patterns to Doors 

To assign a Door Mode Pattern to a Door, proceed as follows: 

 

1. On the menu, select Configuration>Doors. 

2. Click the Door tab. 

3. Select a Door. 

4. Click the Day Mode button. 

5. Select an appropriate Door Mode Pattern from the drop-down 

menu. 

 

 
Each day can have its own Day Mode. 

 

Add Tagholders in Bulk 

To Add Tagholders in bulk, proceed as follows: 

 

1. On the menu, Select Tags>Batch Add Tags. 

2. Select an Access Group. 

3. Select a Tag Level. 

4. Enter a Starting Tag Reference Number. 

5. Ensure the Batch Mode Auto Read option is selected. 

6. Click Start. 

7. Present your Tags to the Reader. 

8. Click Stop. 

9. Click the  button to Save. 

 

 
The Starting Tag Reference Number is a number you write 

on a Tag to identify it. 
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Reports 

Use the IXP120 Reports to view the following types of data: 

 

 Tagholders’ location and access patterns 

 Zone occupancy and zone access patterns 

 In and out times, and duration of occupancy 

 

To view the IXP120 Reports, do one of the following: 

 

1. On the Toolbar, click the  button. 

2. On the Menu, select Reports > Web Reports. 

 

Reports are web-based.  Therefore, they are accessible from any 

workstation connected to the IXP120 Host PC’s network.  To access 

Reports in this manner, type the following URL into your Internet 

browser software: 

 

http://localhost/webreports/servlet/net.impro.ipx1.web.webreports.SiteSe

lReport 

 

 
Replace localhost with the name of the Host PC. 

 

Web Reports Password 

Use a password to restrict access to Web Reports.  To do so, proceed 

as follows: 

 

3. On the menu, select File>Web Reports Password. 

4. Enter a password in the New Password textbox. 

5. Enter the same password in the Confirm Password textbox. 

6. Select the Enable Passwords For Web Reports checkbox. 

7. Click the  button to accept, or click the  button to cancel the 

operation. 

http://localhost/webreports/servlet/net.impro.ipx1.web.webreports.SiteSelReport
http://localhost/webreports/servlet/net.impro.ipx1.web.webreports.SiteSelReport
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Anti-passback (APB) 

An APB access control system does not accept a Tag more than once in 

the same direction until that Tag is processed in the opposite direction, 

and vice-versa.  This ensures the Tag is not passed back to another 

person to gain entry.  To enable APB, proceed as follows: 

 

1. On the menu, select Configuration>Doors. 

2. Select a Door. 

3. Select one of the following APB Mode options: 

 Strict 

 Relax 

 

 
In Strict mode, Tagholders must tag-in before they can tag-

out, and vice-versa.  In Relax mode, Tagholders can tag-out 

more than once, but can only tag-in if they have tagged out. 

 

APB Lockout Delay 

To set the amount of time that a Tagholder is locked out after exiting an 

APB zone, proceed as follows: 

 

1. On the menu, select Configuration > Controller. 

2. Enter the APB Lockout Delay in minutes. 

 

Reset Anti-passback 

Activating this function resets Anti-passback for all Tags in all zones, to 

neutral.  The IXP121 system accepts any Tag in any direction, but only 

for one transaction per Tag.  To reset Anti-passback for the connected 

Site, proceed as follows: 

 

On the menu, select Hardware>Reset Anti-Passback. 

  



 
 

 

IXP321-0-0-GB-02 October 2007 Page 23 

 

Replace Units 

Replacing Controllers and Terminals is a complex process.  Details are 

provided in the IXP120 Help.  To access these details, open Help from 

the IXP120 Software and navigate to Advanced Features>Replace 

Units. 

 

Database Backup 

The IXP120 Software does not have an automated backup feature.  

Therefore, the IXP120 databases must be manually backed-up at 

regular intervals. 

 

 
We recommend backing up the IXP120 database on a monthly 

basis, or each time that there are changes made to the 

System. 

 

 
Ensure that the IXP120 Software is closed and inactive when 

you perform the backup procedure. 

 

To manually perform a backup, proceed as follows: 

 

3. In Windows, browse to the C:\IXP120\folder. 

4. Select and copy the Database folder. 

5. Paste the Database folder to a secure location on your network, or 

archive it to CD, DVD, or tape, as per your company's backup 

policy. 

 

 

USER NOTES 
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USER NOTES 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This manual applies to V5 and upwards of the IXP120 Software.  (The last two 
digits of the Impro stock code indicate the issue status of the product). 

IXP321-0-0-GB-02 Issue 03 Oct 2007 
IXP120\Software\English Manuals \Latest 

Issue\IXP120QS-swm-en-03 Draft 01.docx 
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